We did this in Norway a while ago. If I remember correctly there's a vbs version dependency. I think we were running 3.9.2 or something.